Problemi con Firefox Quantum? Niente paura, c’è Firefox ESR.

Logo_firefox57_esrPiccolissima segnalazione che potrebbe risultare utile a qualcuno in questi giorni. Da poco è stato rilasciato ufficialmente Firefox 57 Quantum, disponibile da ieri anche nei repo ufficiali di Ubuntu e derivate.

Se molti utenti si dicono entusiasti della nuova veste grafica e delle prestazioni, altri lamentano alcuni problemi (ad esempio la non compatibilità con alcuni add-on). In questo caso si può utilizzare Firefox ESR, una versione con supporto esteso (la stessa utilizzata da Debian). Quest’ultima, attualmente alla versione 52, conserva la precedente veste grafica ed è compatibile con quasi tutte le estensioni funzionanti in Firefox 56.

Non è nei repositories ufficiali di Ubuntu ma si può installare:

  • dal sito ufficiale (scegliendo la versione Linux adatta per la propria lingua e architettura)
  • dai PPA dedicati (per Ubuntu 14.04 e 16.04)

Per la seconda opzione ecco i comandi da dare nel terminale per rimuovere la versione standard di Firefox e installare quella ESR:

sudo apt-get remove firefox
sudo add-apt-repository ppa:jonathonf/firefox-esr
sudo apt-get update
sudo apt-get install firefox-esr

Fatto!

Enjoy!

UPDATE: Altre informazioni aggiuntive. Per gli utenti che usano Ubuntu 17.10 oppure che desiderino mantenere la versione corrente di  Firefox accanto a quella ESR, è possibile utilizzare i PPA Mozilla Team:

sudo add-apt-repository ppa:mozillateam/ppa
sudo apt-get update
sudo apt-get install firefox-esr
Annunci